ioncube not loading? This might be the fix!

Recently, a client reported that one of their websites was not loading all of a sudden due to an “ioncube” error that suddenly appeared. After checking out the error, it was apparent that the loaders were not loading and the page directed me to update my php.ini file with the location of the loader file. Simple enough right? Wrong. After checking about 30 times to make sure all my file paths were right in the php.ini file, I finally asked the client if anything had changed on the server recently, as I knew it was working at one point. I was told that the server was changed from CentOS 32-bit to 64-bit. Aha!

This gave me some traction.. I broke my number one rule of “check the log files first”, but eventually it’s where I ended up. In it, you will see an error that says something along the lines of “wrong ELF class: ELFCLASS32“. A bit cryptic, but it basically means you’re using the 32-bit loaders on a 64-bit system.

Head on over to the ioncube site and download the zip file containing the 64-bit version of the loaders.

Convenient Link Alert: http://www.ioncube.com/loaders.php

Once downloaded, you need to upload them to your ioncube directory using “binary” mode of your FTP client. Once uploaded, that should be all. Refresh your error-ridden page and you should be staring at an error-free page!

Go grab a rock star and add one to the win column!

Like it? Share it:

Leave a Reply

Your email address will not be published. Required fields are marked *


*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Notify me of follow-up comments via e-mail. You can also subscribe without commenting.